This article only applies if you host your own AMS 360 server.  

Quick Checks

If your integration from AMS360 to Fuse has completely stopped, 9 times out of 10 the following quick checks will solve the problem:

  1. Check for & Resend any Undelivered Notifications
    If even one notification gets stuck in AMS360 without being delivered to Fuse, it will block all further notifications from being sent. Essentially, it creates a log-jam in Vertafore's Notification service and all subsequently attempted notifications get "stuck" as well.  To solve this, in AMS360, go to "Undelivered Notifications". If you find any unsent/stuck notifications there, click to "Resend All".
  2. Double-Check your Notification Service Settings
    If the previous check didn't solve the problem, go to Notification Service Setup in AMS360 and make sure the settings are still correct (if you need a refresher on what the settings should look like, go to your list setup page in Fuse and follow the applicable setup steps). 
  3. Double-Check your WebServices API Setup
    If that didn't do the trick, double-check that your *Web Services API Setup" is correct in AMS360 (This can also be found by clicking the applicable setup steps on your List Setup page in Fuse).

If so, and if the sync is still not working, here are most common causes and solutions:

Advanced Issues

NS Depot Service Stopped Running

"NSDepot" is a Windows Service that runs on your AMS360 server, and is responsible for sending notifications to Fuse when you modify or enter new data in AMS360. Occasionally, this service may stop running and need to be restarted.

How to check/restart your NSDepot service:

  1. Log into your AMS360 server. This must be the computer that hosts AMS 360. You may need your IT department's help.
  2. Hit Win+R on your keyboard to pull up the "Run" window.  ("Win" is the key that looks like the Windows icon, near the Ctrl and Alt keys)
  3. In the Run window, type services.msc and click Run
  4. This will pull up the services window. The list should be alphabetized. Scroll down to locate the service named "NSDepot".  Right-click and select "Properties"
  5. About half-way down it should show you the "Service status".  If the status is stopped, click the button to Start it.  If it's running, you can try stopping and starting it again for good measure.

ONSInitiator Stopped Working

The ONSInitiator can also be found on your AMS360 server.

We do not currently have instructions on where to find it or how to restart it, but we are aware of at least a few cases where all troubleshooting steps up to this point did not solve the issue, so our users contacted Vertafore support. After a lengthy investigation by Vertafore's support team, it was eventually discovered that the ONSInitiator was the source of the failed notifications.

We offer this information mainly to help you save time with Vertafore support, as they may not be sure where to start.

How to check/restart your ONSInitiator

  1. Contact Vertafore Support
  2. Tell them:
    • You have AMS360 self-hosted on your own server
    • You have an API-based integration with Agency Revolution.
    • You've already double-checked and verified that your Web Services API and Notification Service are both setup correctly on both ends (in AMS360 and on the Agency Revolution side)
    • You've already double-checked and restarted your NSDepot service
    • Notifications are still not being sent
    You need help from Vertafore's tech support to make sure the NSDepot service is working (this is the real point of contacting them, but the process will go more quickly if you share the additional info above)

Please be aware that If the ONSInitiator has been restarted/fixed, you may need to go back to the NSDepot service to make sure it's still running.

A Final Note

If you've covered every troubleshooting step up to this point and are still having issues (which is unlikely) try restarting your server and making sure the Windows Service Broker itself is running properly.

Did this answer your question?